Tools and selections

Tools and selections

Most of the menu and toolbar editing functions in the Rosegarden Notation editor fall into one of three categories: “tools”, “functions that operate on selections”, and “drag operations”.


The basic tools are the selection tool, the erase tool, and those for inserting notes, rests, text and so on, which are usually accessed from the toolbar buttons.

The insert, erase, text, and guitar chord tools

Choosing a tool changes the default behaviour of the mouse buttons on the main notation canvas, at least until another tool is chosen instead. For example, choosing the selection tool allows you to make selections and so to use the selection-based functions (below); choosing an insertion tool (such as one of the notes) switches the GUI's behaviour so as to insert notes by clicking on the canvas; choosing the erase tool allows you to remove events by clicking on them.

You can also change the current tool using the Tools menu.

Functions that operate on selections

The majority of the remaining menu functions require a selection to be made on the canvas before they can be used. Some of them (such as Cut or the Note Style functions) will operate on any selected events; others (Stem Directions function) will refuse to work unless the selection contains some notes.

To select some events on the canvas, switch to the Select (arrow) tool and then outline a rectangular area containing the events you want to select. The selected events will then be highlighted in blue. If you click on a single event, just that event will be selected [4]).

If you hold Shift while dragging out a rectangle, its contents will be added to any existing selection instead of replacing it.

To select a whole bar, double-click with the Select tool on some empty space within that bar; to select the whole staff, click three times. The Edit menu carries functions for selecting extended areas based on the location of the insert cursor, and you can also select events around the insert cursor by holding Shift and pressing the left or right arrow keys.

It is not possible to select events from more than one staff at once.

After selecting some events, you can filter your selection further using the Edit->Filter Selection function. For more details, refer to the corresponding function in the matrix editor.

Drag operations

You can also do a certain amount of editing just by dragging things around. Switch to the Select (arrow) tool, and then you can change the pitch of notes by just click-and-dragging their heads up or down, and change the times of notes and other events by dragging them left or right. (You can't drag rests or time signatures, but you can drag everything else. If you have more than one event selected, the whole selection will be dragged at once.)

Dragging is usually a less accurate way of editing things than using the menu or toolbar functions, but it can be easier.


Transposing by interval

In Notation view menu there are two functions which can be used to transpose notes by an arbitrary interval, namely Adjust->Transpose->Transpose by Semitones function which asks just the number of semitones to be transposed, and Adjust->Transpose->Transpose by Interval function which shows a neat dialog that can be used to transpose notes. In the latter, the dialog shows an example notes before and after transposing and expresses the interval in written form. The interval may be changed either by dragging the notes shown by the dialog or by changing separately the base note, its octavation and accidentals.

In Segment view, Notation view, and Track view there is also Segment(s)->Transpose by Interval function which makes a transpose to entire segment. In this dialog you may also choose whether only the notes are transposed or the keys of the segment are transposed also.

[4] You can also double-click on a single event to open an editing dialog for that event, but that's got nothing to do with selections.