Differences

This shows you the differences between two versions of the page.

Link to this comparison view

dev:eclipse [2013/07/27 00:44]
tedfelix [Configure and Build] Add run step
dev:eclipse [2014/07/20 01:48] (current)
tedfelix Add unlimited console buffer section
Line 63: Line 63:
  
 ===== Set Up Rosegarden Source Under Eclipse ===== ===== Set Up Rosegarden Source Under Eclipse =====
-//Note: These instructions were developed using Eclipse 4.(Kepler).//+//Note: These instructions were developed using Eclipse 4.(Luna).//
  
-Since we set up the directory structure in a way that Eclipse likes, getting Eclipse to find the source and work with it is easy.  Launch Eclipse.  It will first ask for the location of your workspace.  Give it the rosegarden-workspace directory that we created earlier.  Since this is a new workspace, you'll get the Eclipse welcome screen.  On the far right is a button for the "Workbench".  Click it.+Since we set up the directory structure in a way that Eclipse likes, getting Eclipse to find the source and work with it is easy.  Launch Eclipse.  It will first ask for the location of your workspace.  Give it the rosegarden-workspace directory that we created earlier.  Since this is a new workspace, you'll get the Eclipse welcome screen.  In the upper right is a button for the "Workbench".  Click it.
  
 Go to File > New > Makefile Project with Existing Code.  In the "Project Name" field type rosegarden-svn.  For the "Existing Code Location" provide the path to the rosegarden-svn directory.  In the Toolchain list, select "Linux GCC".  Click Finish.  You should now be able to build with Project > Build All (Ctrl+B). Go to File > New > Makefile Project with Existing Code.  In the "Project Name" field type rosegarden-svn.  For the "Existing Code Location" provide the path to the rosegarden-svn directory.  In the Toolchain list, select "Linux GCC".  Click Finish.  You should now be able to build with Project > Build All (Ctrl+B).
Line 93: Line 93:
  
 ===== Faster Builds ===== ===== Faster Builds =====
-If your machine has multiple cores and/or hyperthreading, you'll want to set up make for multiple jobs (make's -j option).  To do that within Eclipse, go to Window > Preferences > C/C++ > Build > Environment, add an environment variable MAKEFLAGS, and set it to "-j 4" (or whatever is best for your hardware, the nprocs command will tell you how many cores you've got).  This will tell make that it can run four simultaneous compiles.+If your machine has multiple cores and/or hyperthreading, you'll want to set up make for multiple jobs (make's -j option).  To do that within Eclipse, go to Window > Preferences > C/C++ > Build > Environment, add an environment variable MAKEFLAGS, and set it to "-j4" (or whatever is best for your hardware, the ''nproc'' command will tell you how many cores you've got).  This will tell make that it can run four simultaneous compiles.
  
 ===== Scalability Mode ===== ===== Scalability Mode =====
Line 100: Line 100:
 ===== Auto-Save Before Build ===== ===== Auto-Save Before Build =====
 By default, Eclipse doesn't automatically save your files when you build.  If you would prefer that behavior, go to Window > Preferences > General > Workspace.  Set the "Save automatically before build" checkbox.  This avoids build errors if you forget to save a file that you've changed. By default, Eclipse doesn't automatically save your files when you build.  If you would prefer that behavior, go to Window > Preferences > General > Workspace.  Set the "Save automatically before build" checkbox.  This avoids build errors if you forget to save a file that you've changed.
 +
 +===== Unlimited Console Buffer =====
 +By default, Eclipse limits debug console output to 80,000 bytes.  Rosegarden generates a lot of debug output.  It's a good idea to turn this limit off.  Go to Window > Preferences > Run/Debug > Console.  Uncheck "Limit console output".
  
 ===== Upgrade Notes ===== ===== Upgrade Notes =====
Line 113: Line 116:
   rosegarden-workspace/rosegarden-svn/.settings   rosegarden-workspace/rosegarden-svn/.settings
  
-===== Ubuntu 12.04-13.04 Issues =====+===== Ubuntu 12.04-14.04 Issues =====
  
 ==== Unity Icon ==== ==== Unity Icon ====
 
 
dev/eclipse.1374878655.txt.gz · Last modified: 2013/07/27 00:44 by tedfelix
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki