Audio File Manager

The audio file manager with one file loaded

The Audio File Manager allows you manage the audio files associated with audio segments in your composition. You can use it to:

  • import audio files from other sources (other projects, ripped CDs, etc.)
  • insert audio segments into your composition
  • export audio segments as audio files

Supported Audio Formats

The following formats are supported: .wav, .ogg, .flac, and .mp3. Wave files (32-bit IEEE-format .wav) are used internally by Rosegarden and importing other types implies that they will be converted on the fly for internal Rosegarden use. Likewise if you wish to export a given audio segment, it can be exported in any of the supported formats.

Overview

You can drag-and-drop audio files from many sources into the audio file manager, or you can open them using its File menu. Then you can either drag-and-drop them onto Rosegarden's segment canvas, or use the audio file manager's Action → Insert into Selected Audio Track menu, provided the current selected track in the main window is assigned to an audio instrument. Newly-recorded audio segments also appear in the audio file manager dialog.

Details of the audio files associated with a particular composition are saved with that composition, but the audio files themselves are not. You should ensure your document has a sensible audio file search path using Composition → Edit Document Properties… → Audio so as to keep your audio files accessible together. You can also export your project to a Rosegarden Project Package file (.rgp) using File → Export → Export Rosegarden Project File to collect any scattered audio files together in one place.

File Menu

Add Audio File...

A standard Open File dialog appears which allows you may navigate to your file and Open it. The file will then appear in the list of available files.

The display includes file details including its name, duration and sample rate.

FIXME What's the current status of resampling? I deleted the old warning about audio files whose rates don't match the JACK rate. I haven't really done much with this new code yet, but isn't that a non-issue now? By way of answer, if this assumption is correct, delete this fixme section and the following text:

DELETEME The audio manager dialog also shows the sample-rate and other information for each audio file, and marks with an asterisk any audio file whose sample rate does not match that of the current JACK audio session that Rosegarden is using. Rosegarden will resample these files at playback time using a very low quality zero order hold resampler. You are advised to resample them separately using a separate dedicated audio editor instead.

Export Audio File...

This becomes available when either an audio file or an audio segment associated with that file is selected.

Segment associated with audio file selected

Suggested Uses

This feature can be useful for:

  • Saving a native-format copy of a file that Rosegarden had to convert from some other format
  • Saving the portion of an audio file used by one particular segment out as a separate file
  • Saving a file out to some more accessible location, with a human-readable name1)

Close

Exits the dialog

Edit Menu

Becomes active when at least one file is selected.

Unload Audio File

Unloads the audio file, and deletes any audio segments that are associated with it. Once the file is unloaded and the segments deleted, you may lose track of a file with a name like rg-20060111-153831-1.wav. Use with caution.

Unload All Audio Files

Unloads all audio files, whether they are associated with any audio segments or not. If any files were associated with audio segments, those segments will be deleted, and those associations will be lost permanently, and you may lose track of files with obscure names like rg-20060111-153831-1.wav. Use with caution.

Unload All Unused Audio Files

Unloads all audio files that are not associated with audio segments. This is most useful when you have loaded files from some external source that you no longer wish to associate with audio segments. If you want to clean up (ie. permanently remove) abandoned files from bad recording takes, consider using Delete Unused Audio Files instead. If your aim is to clean up junk, it is best to do so while Rosegarden still has some knowledge of the audio files that were previously associated with audio segments.

Delete Unused Audio Files

Unloads all audio files that are not associated with audio segments, and permanently deletes them from your hard disk! This feature is very useful for cleaning up junk after a recording session. If your aim is to clean up junk, it is best to do so while Rosegarden still has some knowledge of the audio files that were previously associated with audio segments. However, this feature will remove files permanently. Use with caution.

Action Menu

The functions on the Action menu will not become available until you select an audio file.

Play Preview

Plays the selected audio file, or the portion of the file associated with the selected audio segment.

Buggy and unreliable, this function may not work.

Insert into Selected Audio Track

Inserts the selected file into the audio track you have selected on the main window segment canvas. If this function is not available, you probably do not have an audio track selected on the canvas.

Distribute Audio on MIDI Segment

FIXME Damn if I know. I'd go read the help, but this is the help.

1) When you record, Rosegarden gives each recorded file a name like rg-20060111-153831-1.wav, which can make it difficult to find your files if you want to do something with them in some other application.
 
 
doc/audiomanager-en.txt · Last modified: 2013/07/02 12:55 (external edit)
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki