21.12 Testing Notes

21.12 will be released on December 8. Please test the latest version of Rosegarden in git as much as you can. If you've not built Rosegarden before, give it a shot and let us know if you run into trouble. We'll walk you through it.

I've written up instructions on the wiki that should help you through the build process. To help out with 21.12 you can either download a source snapshot, or use git to stay up to date with the latest.

Suggested areas to test:

  • Main Window
    • Undo should now preserve playback pointer position.
    • Track > Add Tracks…. Test the new Device and Instrument fields.
    • File > Merge > Merge file…. This has been rewritten and could use some testing of all features.
    • Opening a file that is already opened by another instance of Rosegarden will cause a pop-up dialog. Test the new “Ignore” button.
  • Edit > Preferences
    • Printing: General > External Application > Command-line file printing utility. Test each setting.
    • File open/save dialogs: General > Presentation > Use native file dialogs. Changes appearance of file dialogs.
  • Matrix Editor
    • “Adjust > Collapse Equal-Pitch Notes” across the bar. (This now creates a single note instead of two notes tied.)
    • Deleting segments (in the main window) that are currently being displayed in Matrix. Especially when multiple segments are being displayed in a single Matrix editor.
    • Ruler Persistence. Make sure that the rulers that were opened in Matrix for a segment come up when that segment is brought up again in Matrix. And make sure they show the data correctly.
    • View > Show note names. Adds note names to each note.
    • View > Highlight > Highlight Black Notes
    • View > Highlight > Highlight Triads
  • Notation Editor
    • Selection using the keyboard (shift + arrow-keys). Especially notes at the end of a segment.
    • Inserting grace notes. (Bug #1520)
    • Inserting tuplets with the keyboard.
    • Ruler Persistence. Make sure that the rulers that were opened in Notation for a segment come up when that segment is brought up again in Notation. And make sure they show the data correctly.
    • Text should now display correctly and consistently. Use the Text tool to insert various kinds of text (e.g. Tempo and Local Tempo). Save, reload and make sure everything is as expected.

Most importantly, do what you usually do. That will hit the areas that I missed.

Thanks.

 
 
dev/21.12_testing_notes.txt · Last modified: 2021/11/11 17:27 by tedfelix
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki