This is an old revision of the document!

Rosegarden 10 Fake Bug Tracker

We're just using this wiki page as a tracker for now. To report a bug, just jot something down, preferably at the top of the stack, using docuwiki numbered list syntax (like the existing examples.) To claim a bug, tack your initials after it in brackets, like [dmm] or [cc]

Style Bugs [dmm]

Feature Review – an attempt to go through all, or at least most, dialog-type features and sort them into “OK” and “not OK”


Bugs in the Matrix

Bugs in the Note Editor

  • Status bar resurrected, but it's terribly broken
  • Newly selected segment not highlighted properly following Prior/Next Segment navigation control (And after about two or three next/previous cycles, nothing is ever painted blue again, although the status bar shows a varying number of events selected, consistent with the selection that's supposed to have changed. I wonder about this one anyway. Should we really select everything? It seems like the failure to select is less a bug in of itself than the failure to do a better job of showing which bit of what is active now. Suggests putting inactive notes in an off color, or even drawing a different background under the active area. Probably all out of scope for Thorn.)
  • Just after a segment is opened the cursor is not shown (is this a bug ?)
  • Rosegarden goes segmentation fault while adding slur. (Yves? I can't repeat this. More details.) - Gentoo amd64. This: is log for that event. - Bug 2918002 related? : the trace of this last bug shows a crash in NotePixmapFactory::makeSlur(). I can't reproduce any of them (yg). - 10.02-beta works corectly
  • Shift+drag repositioning is very seriously buggy, and not usable

Bugs in the Arranger

  • Parameter area gets extremely wide in Russian for no obvious reason (no obviously extra-wide strings). (I don't read a lick of Russian, and just happened to notice this while trying different locales investigating another problem.)
  • There's a rather subtle bug with parameter box instrument labels. IPB instrument labels are initialized completely null, so the first time you look at a MIDI track its instrument label will be blank. Scroll down with the down arrow and the label shows up starting with the next MIDI track you reach (typically track 2). When you reach the first audio track, its label will be blank again, and then the next audio track and every one thereafter triggers correct updates with each new change. These updates are happening in AudioInstrumentParameterPanel or thereabouts (and presumably the MIDI ones in the MIDI equivalent, although not investigated). It seems to be they're starting out blank completely outside of AudioInstrumentParameterPanel, and it looks like it might be some weird studio-related problem. There's a similar problem with the instrument portion in the TPB, where that one omits the “[ Track 1 ” before “<untitled>” and the “]” after.

Bugs in Menus or Toolboxes

Bugs anywhere else

  • There are issues with the default audio path (~/rosegarden) not always being created on demand (or maybe never created on demand) which can lead to brokenness in assorted ways, like drag and drop failing. This report is a reminder stub.
  • quantize dialog, layout goes screwy when changing to legato quantize

Bugs that were listed above, now fixed

  1. Audio or synth plugin dialog, the Editor button never enables (but the one in the IPB works) (Never fixed properly, but good enough for now. Hack the thing always enabled. Not ideal, but I didn't find any serious side effects. (Same thing with the “(no object)” warning. There are ghosts in this machine, but they seem fairly benign.)
  2. NASTY! Tempo/Time editor delete function got horribly mangled in translation, and the new implementation was obviously hasty, without much real thought about what any of it was for.
  3. Selecting a quantisation in the matrix doesn't apply/change anything. (Ironed out selection state whatnots so the Q is disabled unless there is a selection. I have no idea what the Quantize combo is supposed to do, but if I make a selection and then change its value, the selection goes away, implying something happened.)
  4. Matrix cursor control needs sorting
  5. Stacking order is not always correct for events with multiple segments open. (Doesn't seem completely credible, but it's a lot less glitchy than when originally reported.)
  6. BUG Quantize dialog layout needs some margins/padding, because group box contents are running over the group box labels.
  7. BUG Quantize dialog goes VERY wide when the type combo changes to Legato. [Not really. It was staying the same width and getting much narrower contents without resizing properly. I settled for less than I wanted sorting that out, but it's good enough now. Just a little clunky instead of grossly clunky.]
  8. BUG Control/property rulers still appear in continuous page and multiple-page layout modes. [You don't want to lose reading the closing comment on the SF tracker in all this wiki noise.]
  9. BUG Something is going wrong with symbols and the “have selection” action state. [Not really. There were no action states for anything but notes or rests. Now we have them for symbols and clefs. Other things might justify the same treatment in the future, and if noticed, they should follow the “have_clefs_in_selection” bread crumb trail for a quick couple minutes of hacking]
  10. normalize rests doesn't work
  11. collapse equal pitch notes doesn't work
  12. BUG Double clicking the staff should select a bar. (Chris fixed getBarExtents(). Thanks, Chris!)
  13. BUG Double clicking on a note should open the simple event editor.
  14. BUG Shift+double clicking on a note should open the advanced event editor.
  15. BUG Double clicking on clefs should open the clef editor. It does not work.
  16. BUG Double clicking on time signatures should open the time signature editor. It does not work.
  17. BUG Triple clicking the staff should select the whole staff. [double clicking to select a bar still broken]
  18. BUG In multiple-page layout mode, the title, composer and so on are printed in WHITE. When did that happen? MUST FIX
  19. BUG Increase and Shift+Up [to raise velocity in notation editor] do not work.
  20. BUG This [set event velocities] dialog is completely frigged up.
  21. BUG or FEATURE? If a segment starts before the composition end marker, notation and matrix views show and allow access to the entire segment, even though some part of it is not properly part of the composition. This one isn't crystal clear, but I think since it confused me enough to flag it as a bug, it's a bug, and I fixed it.
  22. Drag and drop in the audio file manager needs a complete rewrite [Emanuel fixed this some time ago, and it generally seems to work fine. Dragging and dropping on the segment canvas too.]
  23. Invisible notes looked like ass. Now they have stupid halos. Acceptable
  24. FIXED When choosing a clef with an 8 or 15 above it, the text gets cut off, and the entire 8 isn't visible. (After a lot more experimentation than I planned on, the fix that worked was to make an adjustment as documented in the comment in 11270. Works for me, but who knows how it will do elsewhere. It seems like a lot of random things could impact this.)
  25. BUG Shift+Click with the select tool should add to a selection bit by bit.
  26. BUG No vertical separation between slashes (in notation). They glob together. (fixed by +1 the gap which is crude, but effective)
  27. Crash after a resize: make a notation editor window small enough that you can just barely edit one bar, try to insert or even just select something, and boom, a crash in a playback pointer update race condition. slotEnsureVisible() probably. Anyway, I detoured around it, and the crash is averted. Any housekeeping I leave to someone else
  28. Staff lines rendering problem [fixed by Ilan Tal: always draw staff lines in black; with or without this, notation below size 4 is totally illegible anyway, so I say leave it, rather than trying to fix the back to black suitably]
  29. do re mi shortcuts don't work in most non-English languages I tried (eg. Spanish) (That was involved! Should work now though, unless translators screw something up in their individual translations)
  30. New user welcome box shows up untranslated even there is proper translation available.
  31. adding an audio file from the audio file manager never works, but instead hangs the GUI (it gets stuck in SeqMan; works fine when audio is disabled due to JACK not running or startable) (90% sure this is fixed, but did not test just now)
  32. The matrix status bar hint thingie referenced here has yet to be implemented. Do we care? I don't, much. (Yes. I do, anyway. The notation status bar icons and suchlike are missing, too. Fortunately these things shouldn't be hard to fix –cc) (Note: Chris, this is your baby. It's more of a bother to sort than I care about. I've only looked at notation, but stuff this bit in View this bit in Widget this bit in Scene whatever, oh bollocks to that. It may be less trouble just to establish what it used to do and rewrite it all from scratch with the new structure in mind from the beginning. I'm finding that to be increasingly the case for these stragglers.)
  33. Initial setup for matrix or notation views with long segments was coming out completely stupid, and it was driving me fricking nuts. I worked out a “grab the scrollbars with the hand of god” hack that finally accomplished a sensible result. Comparing against Classic, using the same test file in both (20 staffs of segments 50 bars wide), Classic opened notation all the way left with staff 3 at the top for no discernible reason (I tried playing with different input variables to try to affect the outcome,and it was always staff 3), while Thorn now comes out all the way left and staff 1 visible. On matrix, Classic was all the way left, and C5 on the keyboard centered, while Thorn is all the way left and C4 centered. Close enough for me (the hack does not change the default vertical scrollbar position in the matrix) and the new behavior is a tiny bit better on notation. The method used is just ghastly, but a functioning baseline is established, and I am happier now. Win.
  34. Fix matrix toolbar toggle stuff
  35. Matrix note entry stuff missing
  36. Your last saved path was /tmp/test/foo.rg Go to File → Save and the dialog comes up in /tmp/test. Type “~/new-foo.rg” and you get a failure to save to /tmp/test/~/foo.rg. This probably applies broadly and needs sorted out, but I'm just jotting down a quick note at the moment.
  37. The “Event filters” check boxes in the event list window don't appear to work (quite important) (quite the little project to fix too, bleargh!)
  38. time/tempo multi-selection related crash fixed by dumping pointless multiple selection behavior
  39. time/tempo filter checkboxes were broken terribly (fix shall be applied to MIDI filters as soon as practicable)
  40. double clicking one of the list items in the tempo/time editor does not open the editor
  41. the “insert tempo change” dialog has no OK button, so there's no way to do anything with it! (probably missing a QDialogButtonBox or the layout is broken in some way)
  42. No bank/key map editor
  43. No font size zoom combo boxes on the layout toolbar
  44. When flipping through (audio or synth) plugins, if you go from one with a small number of controls to a large number of controls, the dialog gets bigger. If you go in the other direction, you wind up with a huge dialog with a small number of controls and a vast amount of empty space. (I fixed this one awhile ago, although I forget how. Something about setAutoExpanding(true) or something or other.)
  45. While re-testing old bugs to weed out obsolete ones, I discovered that I can get a crash. [confirmed multiple times this crash is no longer repeatable; no idea when it got fixed or as a consequence of what]
  46. Deleted notes are audible. Insert some notes and delete them. Hit play button. You will hear the sound but can't see the events. Same happens in notation editor too. Deleted notes don't show up in event list editor either. (This is very subtle and tricky. I had to try for some time to get this to show up. I can't write out a recipe for repeating it simply at the moment.)
  47. Text size in (staff) headers should not change with zoom level. (DMM - I disagree. If it didn't change, it would be too hard to keep track of what bit of text belonged with what staff. Staff goes gigantic, so does the header. Staff goes so small you can't really read it, so does the header. This feels right to me. I say leave it. Having normal 9 px text with a 300 pixel tall staff would look goofy.)
  48. The headers group is not always resized when the main window is. - Should be fixed now.
  49. Track headers Headers tool tips are not shown correctly. (damn strange, n'est-ce pas?) (Not so strange : it's related to the header widgets being embedded inside a QGraphicsScene/QGraphicsView to facilitate the zoom implementation.) - Should be fixed now.
  50. Color (red of warning) is not handled correctly. (fixed by DMM; also inverted the colors to white on black to good effect) [not quite sorted 100% but good enough to close this]
  51. File → Close crashes the application in src/document/RosegardenDocument.cpp:196 [This got sorted along with all the WA_DeleteOnClose whatnots, I'm pretty sure. Anyway, it's fixed now.]
  52. Loading a document from the command line causes a laundry list of problems, really, while loading the same document from a running Rosegarden via File → Load causes none of these problems.[fixed by the studio push rewrite; not sure what other problems might remain]
  53. tricky to sort and get this one right, a ton of things aren't setting the document to modified, so it is possible to close with no protest after making extensive edits and accidentally clicking the wrong window button… hopefully/maybe they all have some simple common root
  54. Either chord entry mode is stuck always on regardless of the apparent setting of the toggle, or entering notes with the do-re-mi shortcut keys is otherwise broken. They all wind up chords. (Could also be the old purple cursor being missing, and this code needs to be adapted to accommodate its absence.)
  55. Settings → Configure in notation editor crashes – there is a distinctly malodorous configDlg→m_tabWidget→setCurrentIndex at EditViewBase.cpp:109 which presumably needs to be modified to reflect a changed structure of widgets in ConfigureDialog (in fact neither ConfigureDialog nor its base class uses m_tabWidget; why is it still present in the class?)
  56. There's no save icon in here, and it's been driving me nuts while working on a real tutorial that's actually unfolding successfully.
  57. File dialog doesn't know where to find example files (and neither do I, actually) (unlike many resources, examples will probably want to be installed – and they will be installed at /usr/share/rosegarden/examples I think – but you're right that the dialog doesn't know that –cc) [cc – didn't do shit DMM FTW]
  58. The backend export/print to LilyPond stuff generates J*.ly or T*.ly in . instead of /tmp/somewhere. This used to be /tmp/kde/my_user or something like that, probably from KDE. We should probably do something similar, like /tmp/my_user or something, and ensure that this gets passed into, eg. LilyPondProcessor with the full path intact. Noting for later but not endeavoring to do anything about this just now. Oh, also these temp files need cleaned up when we're done!
  59. Hovering over or doing anything with the segment canvas or track buttons causes thousands of Qt painter errors. These don't actually seem to hurt anything, but they're seriously getting on my nerves whenever I forget to run with 2>&1|grep -v paint to filter all this garbage out. (Note that I have over TWENTY MILLION of these errors in my ~/.xsession-errors after around five months of Thorn actually running and doing something. That's a lot of errors!) [cc rawks!]
  60. The segment parameter box uses a smaller font than the track and instrument parameter boxes. This doesn't show up clearly in all environments; possibly the two sizes are only fractions of a pixel apart. [cc hit this with a bludgeon a few revisions ago]
  61. File dialogs generally need a bit of care and attention to make sure previous paths per file type are used, etc. [hjj] (hjj, yeah right, that didn't work out very well) [DMM]
  62. The left side toolbars should be in three columns. Rest toolbar is hidden off the bottom in a sub-palette by default, and that won't do.
  63. I need to fix the damn title bar stuff. It just says “rosegarden” or something instead of what it's supposed to say. Driving me nuts. (I like the new icons that vary by window though. Kick ass.)
  64. Vertical scrollbar thumb is wrongly shaded (should have darker shadow to right, like the toolbars do when displayed vertically – as it stands, vertical scrollbars appear concave)
  65. if two copies of RG are started, the second one is unable to connect to JACK. Chris says we can sort this out and what needs fixing in an email I've misplaced.
  66. During playback, the matrix and its piano keyboard flickers horribly (seems to move up and down quickly and repeatedly) [this was introduced in 10257 along with the new ruler work. I read this comment and tested it before I had updated, and the problem wasn't evident until after I built the new code. It's jumping up and down madly. This seems to be related generally to the problem with being unable to position the white “viewport” part of the panner anywhere but stuck to the very bottom during playback.)]
  67. Pitch was broken by Arnout's new code to spell accidentals more nicely. Using isSharp == true to try to force sharps no longer works correctly. We only use that code in a few places, and it probably only existed to avoid the need to do the nice job Arnout did much later on, so I've overloaded the function in question, marked the original as deprecated, and will in due course switch everything over to use the new version of Pitch::getAsString() which returns C C# D Eb E F F# G Ab A Bb B (tested and confirmed; now I just have to hunt down all the places that need switched over)
  68. doc properties setting audio path file dialog comes up with “file dialog” in the “type text here” box. That's odd. (The whole bit with how I struggled to remember how to set this makes me think we really should make the audio path more readily accessible too.)
  69. When there is too much tracks to fit vertically into the segment canvas window, rolling down then up the mouse wheel on this segment canvas hides everything on it. [This is the Qt 4.5 raster graphics “scrubbing problem.” The interim solution is to pass -graphicssystem native on the command line. Chris and I are debating whether to keep this and fix it or optimize the code for better performance using the slower vector engine. The change causes other bad side effects too, but I won't enumerate them here.] [fixed by ifdeffing out the QApplication::setGraphicsSystem call, and reverting to native rendering in all cases; I took this decision after noticing that the raster graphics system caused problems drawing the LEDs as well… too many problems on top of problems, and I doubt it's worth pursuing further, though I left the code there in case it is.]
  70. Undo/redo buttons don't appear properly on toolbar [cc] (This one is really starting to annoy the Official Project Stylemeister)
  71. Initial “Open” file dialog (from e.g. Open button on toolbar) only shows Rosegarden files by default; it used to show both RG and MIDI files and I think it should do so. (Actually it used to show RG2.1 files as well – I don't care about that.) [dmm – skipped RG2.1 files]
  72. Configure dialog buttons (across the bottom) have no labels and don't work [not sure what this was about, but I guess CJ fixed it?]
  73. The “file type” dropdown in the file dialog is unreadable – some style problem? See screenshot [dmm - this one was ugly; apparently a bug in Qt 4.5 as far as I can tell, because with a simple application stylesheet consisting only of a few lines of pasted sample code from the Qt website, all combo boxes in our application take scrollbars, even if there are only two items. I can't repeat this outside Rosegarden to file a bug against Qt, but whatever witch's brew of random variables is causing this to manifest is nothing we're doing wrong per se. It's most likely due to Qt3-support, I hazard, but haven't been able to prove that. Anyway, I addressed the issue by ensuring that the unwanted scrollbars would at least be small enough to function, even though they look ridiculously stupid, and I wish I could make them go away.]
  74. controller editor: add a controller, and unless you change the color by hand, it always comes out “default” even when it's hacked to actually default to something other than default; some missing plumbing there[dmm]
  75. just hack the damn rotary drawing code to work around this color map passing around default color bug, because I can't figure it out, and it's not worth more time[dmm]
  76. File Save and picking a new name saves file as “newname.rg *.RG” [dmm - fixed along with the new template bit]
  77. Controller editor dialog had a color index bug for years [dmm]
  78. Controller editor dialog did not allow editing of existing controllers due to broken signal [dmm]
  79. Controller editor dialog layout problems [dmm]
  80. SERIOUS MATRIX SELECTION BUG! Draw, say, four events in the matrix. Sweep select them. Now shift click on one of the events. What's supposed to happen is that if an event is already part of the selection, that event gets removed from the selection. The selection part of this seems to be working properly, but there is a SERIOUS glitch. Every time you shift-click an event that's already part of a selection, all the events that remain in the selection MOVE in time. [Chris apparently just fixed this in rev. 10143, though I'm not sure if he fixed it by design, or as a convenient side effect.]
  81. crash after successful looking audio recording [dmm]
  82. The notation editor core dumps on an empty segment [rev 9704] notation_crash_discussion [although it is light years away from becoming a notation editor again, or at least appears so from the surface]
  83. In Manage Metronome dialog, the pitch chooser doesn't show a note on a little staff. (may be related to general notation view brokenness –cc) (staff and clef are visible again, but no note yet [rev. 9758] –yg)
  84. something's off with whatever keeps various rotaries in sync. If I open the MIDI mixer and tweak the pan control, the knob in the MIDI IPB keeps in step, but this doesn't work for any other knob. [CJ]
  85. right click assignment menus were QPopupMenu. Emanuel got this tweaked implementation off the ground, then dropped the ball. [CJ]
  86. Main composition view doesn't scroll correctly – if I use Select tool to drag “off the top”, the whole widget containing the composition view moves down! It's very weird. (yes, very, very weird -dmm) [cjf]
  87. Rosegarden rotary widgets drawn with incorrect colors or something. They look off. [dmm – the backgrounds are fixed with the new styling work, and the rest of this will fall under the umbrella of changes I'm making in that process. I'm probably going to tweak the colors users can pick from for the knobs, so they coordinate better, and along the way I'm going to try to address this drawing problem, which seems to have something to do with drawing on white instead of on the expected background color.]
  88. Trying to change tabs on the MIDI mixer crashes
  89. Configure dialog contains tab widget inside a tab widget, which is a definite no.[CJF]
  90. The AudioPluginManager dialog was catastrophically broken. Now it's greatly fixed. No more serious layout problems, and it shows all the controls for plugins. It looks OK with style too. [dmm]
  91. TrackVUMeter has all the right bits to be showing the track number texts, but they never appear, [CJF fixed the big problem, and is supposed to be working on tweaking the little problem]
  92. save after previous successful save fails with [hjj]
  93. after saving file “test” then modifying it, the main window title is “test*.rg” Should probably be “test.rg*” I imagine. Oh, nevermind, I thought that was the “document is modified” renaming I seem to remember, but in fact it's just “*.rg” added to the end of the file, and it's actually trying to write “test*.rg” to disk, so it fails. [dmm]
  94. File dialog doesn't seem to know about .rgd or .rgp files, and defaults to * instead of *.rg [hjj]
  95. No File → New on main window File menu [hjj]
  96. File → Save As, save to eg. /tmp/foo.rg leads to dialog “This is not a local file.” [dmm]
  97. the other error about “not local filesystem” or whatever [dmm] (Commented out code poorly adapted from KURL::isLocalFile() that was originally supposed to determine that the file was free of any protocols etc. I'm not sure if this matters, and I'm sure it matters less than just being able to save a damn file at all, so this will certainly do for now.)
  98. all saving fails with either the “failed to rename temporary output file” error or the, um, [dmm]
  99. Parameter area in main view lacks scrollbar (just disappears off the bottom) (and needs a horizontal scrollbar or an enforced minimum size too (I vote scrollbar) (I vote no horiz scrollbar, but more work to make it less stupidly wide –cc) (looking much better now though!) (the current behavior seems great now… it's minimum sized by default, and you can't stupidly make it wider than it needs to be, but you do have the option to make it less wide if you want to, and you get a horizontal scrollbar then, and only then. Best of all possible words, I think. Calling it fixed -dmm)
  100. Ticks on ruler don't have dark gray background [fixed by CJ I guess; rulers top and bottom look normal now] [this is fixed with stylesheets now]
  101. Currently selected track has white foreground, but background does not become dark blue [dmm] [fixed with caveats; this solution really isn't stylesheet compatible, and I'm uncertain how to make it so] [it's fixed with spot stylesheets now]
  102. The transport dialog disappears when the mouse goes outside of the main window. transport_focus [dmm]
  103. the transport dialog disappears when the matrix is open, transport_focus [dmm]
  104. Main window zoom slider is completely trashed, garbled, and apparently dysfunctional [not sure who fixed this, but the default toolbar layout is also fixed now -dmm]
  105. The percussion matrix editor layout is comically borked in innumerable ways; just look at it (dmm - looks more or less OK now, certainly in the ballpark; not sure who fixed this)
  106. The regular matrix core dumps on an empty segment [rev 9704] (dmm - no longer true; not sure who fixed this)
  107. I have yet to get the new RG to actually _play_ anything (though the pointer will move) [cc] [I get noise out of my emu10k1!! nothing else yet though]
  108. The main window is “Untitled” instead of calling itself “Rosegarden” or something. The “Untitled” might be correct for the name of the current document, in which case the application name is simply missing from the title bar. Investigating… [dmm]
  109. Minimum draggable height of main window exceeds 945 px., which is too tall for a 1050 px. high screen with a large KDE panel, and surely much too large for 1280×800/1024×768/etc. [fixed by cc, dmm thinks]
  110. Main window load presets was failing due to legacy slotOk() from KDialogBase → QDialog conversion. Fixed by changing to use overridden accept() instead. Changed throughout code, hopefully all cases are solved now. [dmm]
  111. Transport dialog buttons don't work
  112. Manage MIDI Devices crashes [totally rewritten by Emanuel and the new dialog tweaked somewhat by Michael]
  113. Time sig dialog “big buttons” lack icons
  114. The bit of the transport window that normally shows the current time in the format of choice is empty (it does actually show the numbers when non-zero, it's just missing the default zeroes and punctuation. I think they just need loading in Designer –cc)
  115. Notation editor doesn't set a default tool, so crashes when you move mouse over it unless you can select a tool first [cc]
  116. GUI is very slow altogether – it appears to be stuck in a continuous repaint loop
  117. The transport window “show additional controls” icon is missing.
  118. When playing (trying to play), the transport shows junk like “D#(I18N_ARGU” instead of the octave number [fixed by hjj]
  119. The event list editor has some weird “<numintg>1</numintg>” nonsense in its title (in fact this appears everywhere a %1-parameter argument goes into an i18n() string I think – cc) [fixed by hjj]
  120. Studio → Manage Metronome crashes the application.
  121. QDeferScrollView implementations (e.g. track buttons) do not scroll with the canvas as they are intended to [fixed on canvas by CJ, fix pulled out into DeferScrollArea by Michael]
  122. Event list editor scrolls very slowly. I wonder if this is a tree widget when it should be some sort of list widget? Was there some issue like the new tree widget was the only thing that closely matched the old list widget, or something? I can't remember and I didn't handle this conversion, but I do know that lists using e.g. QTableView in other Qt4 applications scroll much faster than this (dmm - Fixed? I tested with a fairly long segment, and it scrolls very fast here.) (yes, I think this was a side-effect of the general gui repaint loop problem –cc)
  123. Quick marker functions absent from Composition menu
  124. Fader widgets don't update while sliding up and down. Update only happens after letting go. Float is several hundred pixels away from the widget being manipulated, and usually way outside of the Rosegarden window space.
  125. the long pause between black screen and the splash image showing up is getting on my nerves… must find some way to fix this… delay showing anything until the resource is secured and ready or something
  126. In matrix editor, to click and drag on the loop ruler correctly moves the play back pointer, but this pointer is shown sticked at its initial place until the end of the drag operation.
  127. In matrix editor, to shift click on the loop ruler crashes RG [yg]
  128. In matrix editor, there is an annoying “looseness” between matrix and standard rulers when horizontally scrolling [yg]
  129. When tracking playback, the new matrix panner zoom box thingie sticks to the bottom of the panner. If you move it up to where the music you want to follow resides, it always jumps back down to the bottom almost instantly. This is true with Qt 4.5 as well.
  130. Transport toolbar buttons in the matrix aren't connected to anything (and this is quite a little project, actually)
  131. I'm seeing a repaint loop on the text float over the main window's tempo ruler. The text float flickers on and off constantly while the mouse is held over the ruler widget. [I can't repeat this one Chris with either version of Qt I have installed.] (nor me, now –cc)
  132. Currently no recording devices exist out of the box. If I create one and connect it to something, Rosegarden never receives any MIDI from this device. We didn't expose record devices to QJackCtl's MIDI connection manager in 1.7.3, and still don't now, so it makes it hard to diagnose exactly where the breakdown is occurring here. The key debug traces seem to be: “Creating device 3 in Record mode – no connection available Default device name for this device is Anonymous MIDI device 2 [seqman] CreateDeviceCommand::execute - added device 3” and then after I have connected the new device explicitly “ReconnectDeviceCommand::execute - reconnected device 3 to “20:1 UM-2 MIDI 2 (duplex)” but I never receive anything, and haven't been able to figure out where the breakdown is. This one is a pretty serious showstopper, with MIDI recording being something somewhat important and all.
  133. The select tool in the matrix does not work the first time the view is opened – if you open a matrix view on an existing segment with notes in it already, it's supposed to have an active select tool, but I have to switch to another tool and back again before it does anything. Just at the moment I have no idea why this is the case, so all investigations welcome.
  134. Matrix, draw an event, double click to open the simple event editor. Change something, and hit OK. Boom! I looked into this one, but what's going on in here is too subtle for a quick glance, and somebody needs to spend some time tracing around and working this out. It's crashing in Rosegarden::ViewElement::event (this=0x0) at src/base/ViewElement.h:43 from Rosegarden::MatrixSelector::handleMouseRelease (this=0x9589fe0, e=0xbfcba580).
  135. Settings → Configure from notation editor doesn't open to the notation settings page. This was more to untangle than I could be bothered to do tonight, and I would consider this an extremely minor issue from a release perspective.
  136. Start fresh. Double click the tempo ruler. Find the tempo of 120 in the list. Click the edit button. Boom.
  137. Navigation control still needs staff above/below and next/previous segment
  138. No control/velocity rulers! (in notation)
  139. text dialog in notation editor has horrible crawling layout problems and sample text is illegible
  140. Staff headers misaligned when notation editor is opened with 6px font size (which is now the default for multi-staff editors)
  141. Staff headers not shown until an horizontal scroll occurs [yg]
  142. No more tooltips on track headers when font size has been changed [yg]
  143. Unwanted scroll when removing a note :
    1. Open a long segment in the notation editor (ie one from aveverum.rg)
    2. Set the cursor somewhere in the first bar.
    3. Scroll to the end of the segment.
    4. Delete a note with the rubber tool : the view scroll back to the cursor position.
  144. Another unwanted scroll and a note entered at the wrong place :
    1. Open a long segment in the notation editor.
    2. Set the cursor somewhere in the window.
    3. With the pencil tool, enter a note in an other bar (without scrolling) : the note is entered at the right place and the cursor jump to that place (the right behaviour).
    4. Now scroll to have the cursor outside the window and enter a note somewhere : the view scroll back to the cursor position and the note is entered where the cursor was.
dev/qt4_bug_tracker.1262105251.txt.gz · Last modified: 2018/02/07 17:07 (external edit)
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki